Debian dependencies

From Navit's Wiki
Revision as of 08:36, 21 February 2008 by HorWitz (talk | contribs) (New page: (as I'm only running sid on all my computers I don't know if all of those packages are available in Etch or Lenny) == Absolute minimum requirements == libtool automake libglib2.0-dev zlib...)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

(as I'm only running sid on all my computers I don't know if all of those packages are available in Etch or Lenny)

Absolute minimum requirements

libtool automake libglib2.0-dev zlib1g-dev

GTK+

libgtk2.0-dev

SDL

libsdl1.2-dev libcegui-mk2-dev libdevil-dev libglc-dev freeglut3-dev libxmu-dev libfribidi-dev

gpsd

libgps-dev (optional, but certainly nice to have)

espeak

espeak (optional)

speechd

libspeechd-dev (optional, you are better off with using espeak)

dbus

libdbus-1-dev (optional, you most likely don't need this.)

python

python-dev (optional, you most likely don't need this.)