Difference between revisions of "Dependencies"

From Navit's Wiki
Jump to: navigation, search
(remove mention of ./configure - autotools build is deprecated)
 
Line 1: Line 1:
 +
{{warning|1='''This is a page has been migrated to readthedocs:'''https://github.com/navit-gps/navit/pull/880 . It is only kept here for archiving purposes.}}
 +
 +
 
'''Be sure to check the prerequisites before building.'''
 
'''Be sure to check the prerequisites before building.'''
  

Latest revision as of 04:54, 22 September 2019


Be sure to check the prerequisites before building.

Note that most prerequisites are optional, meaning Navit will build without them, but you may find that you have some crucial features missing such as the GUI.

Prerequisites are operating-system dependent:

In general you will need one of ksvgtopng, rsvg-convert or Inkscape to build pre-scaled icons in the xpm directory - the build process will detect if you have one of those installed, and warn you otherwise.

Please see platform specific sections such as Nokia N8x0 for their additional development environment dependencies.