Difference between revisions of "FAQ"

From Navit's Wiki
Jump to: navigation, search
m (espeak on Linux: Added 'env' example)
m (added links to IRC logs, forums and mailing lists)
Line 1: Line 1:
 
There are the most common troubles and solutions for those. Please add your soluted problem here.
 
There are the most common troubles and solutions for those. Please add your soluted problem here.
 +
 +
==Where to search==
 +
[[Contacts|There]] are [http://www.google.com/search?q=site%3Awww.hentges.net%2Firclogs%2F%2523navit IRC logs], [http://sourceforge.net/forum/?group_id=153410 forums] and [http://sourceforge.net/mail/?group_id=153410 mailing lists].
  
 
==Compilation troubles==
 
==Compilation troubles==

Revision as of 14:31, 20 November 2009

There are the most common troubles and solutions for those. Please add your soluted problem here.

Where to search

There are IRC logs, forums and mailing lists.

Compilation troubles

My compilation fails, complaining about GL/glc.h

You are missing the quesoglc package. We may switch to another more common library at some point. It isn't widely used, so maybe it isn't available via your distro's repository. If you can't find it, try to compile it from sources, available on the quesoGLC website

If your running Gentoo, you can grab an ebuild for it here : http://www.kazer.org/navit/quesoglc-0.6.0.ebuild.

Can't exec "autopoint": No such file or directory

You're missing gettext-devel.

configure.in:21: error: possibly undefined macro: AC_DISABLE_STATIC

You're missing libtool.

configure.in:25: error: possibly undefined macro: AC_DEFINE

If autogen.sh complains about missing macro AC_DEFINE or AC_MSG_WARN: You're missing pkg-config

gui_sdl_window.cpp:23:19: error: CEGUI.h: No such file or directory

You need Crazy Eddie's GUI development files. Ususally called cegui-devel or libcegui-mk2-dev.

Navit can't find libgarmin, but i installed it!

Try :

export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/local/lib/pkgconfig/

Then re-run navit's configure

Run time troubles

Navit hangs at "failed to create gui"

Example :

o (process:12367): WARNING **: failed to create gui 'sdl'
Using '/home/kazer/.navit/navit.xml'

Most likely, your navit.xml file is incomplete / erroneous. The best thing to try, is to start navit with the default configuration file :

./navit navit.xml

if you're running it from the source directory.

If it loads, then your configuration file is broken. First, check if you have the <plugins> section at the beginning of the file.

The easiest thing to do to fix this is probably to overwrite your own config file with the one shipped with Navit. Don't forget to read Configuring navit for some tips about the config file, especially if you run the SDL gui (GTK gui should work fine out of the box).

Navit complains: Error parsing 'navit.xml'

Example:

o Error parsing 'navit.xml': Element 'plugins' within unexpected context '(null)'. Expected 'config' at line 4, char 1

In the example the <config> opening and closing tags were missing from the navit.xml file.

My position is reported incorrectly

Most of the time, this is caused by the decimal separator being incorrectly set. Navit tries to override the decimal separator at startup, but the LC_ALL environment variable can block this. You can check this easily : echo $LC_ALL

If it returns something, you can't override your locale settings. You should "unset LC_ALL" and try again. If it works, you got it :)

In gentoo, this is set in the /etc/env.d/<something>locales. You may want to remove or comment the LC_ALL line in that file.

In the GTK gui, accents are broken in the buttons, and i get blank entries in the menus

Same thing as previously. The LC_ALL blocks you from changing the charset.

Configuration Troubles

Navit speaks! But it's all English...

How do you configure Navit to speak one of the other 22 languages? How do you do that on Windows? How on Linux?

espeak on Linux

To get Navit to speak with espeak you can add the following XML to your navit.xml file:

 <speech type="cmdline"
         data="espeak --stdout -ven+f4 "%s" | aplay -"
         cps="15" />

This tells espeak to output in the English language (-ven) using female voice #4 (+f4).

To change the spoken language - say to Dutch - there are two things that need to change: the words that are to be spoken need to be translated to Dutch, and the speech pronunciation has to change to Dutch too.

The first is done by changing the LANG environment variable. Instead of running "navit", use "env LANG=nl_NL navit" to get the Dutch translations. Change "nl_NL" to your preferred locale if you want something other than Dutch. As described above, the LC_ALL variable can be set and cause other translation issues, so I (Sybren) launch using:

 env -uLC_ALL -uLANGUAGE -uLC_MESSAGES LANG=nl_NL navit -c /home/root/.navit/navit-nl.xml


To change the pronunciation -- I'll use Dutch again as an example -- use this in your navit.xml instead:

 <speech type="cmdline"
         data="espeak --stdout -vnl+f4 "%s" | aplay -"
         cps="15" />

For different eSpeak language codes see the eSpeak language documentation.