Difference between revisions of "QML2 GUI"

From Navit's Wiki
Jump to: navigation, search
(Created page with "The QML2 UI is a new UI being currently developed to provide a more modern look and feel to Navit. = Prerequisites = The QML2 UI is currently developed against QT 5.7 The ea...")
 
m
Line 1: Line 1:
 
The QML2 UI is a new UI being currently developed to provide a more modern look and feel to Navit.
 
The QML2 UI is a new UI being currently developed to provide a more modern look and feel to Navit.
 +
 +
[[File:Qml2.gif]]
  
 
= Prerequisites =
 
= Prerequisites =

Revision as of 19:11, 2 June 2017

The QML2 UI is a new UI being currently developed to provide a more modern look and feel to Navit.

Qml2.gif

Prerequisites

The QML2 UI is currently developed against QT 5.7

The easiest way to install QT 5.7 (or greater) is probably to use the QT online installer.

For linux, https://download.qt.io/archive/online_installers/2.0/qt-unified-linux-x64-2.0.5-2-online.run.mirrorlist

For other platforms, https://download.qt.io/archive/online_installers/2.0/

Enabling the QML2 ui

Once you compiled Navit, you can enable the QML2 ui from navit.xml.

  • Change your graphics driver to qt5 :
<graphics type="qt5"/>
  • Enable the QML2 UI :
<gui type="qt5_qml" enabled="yes" />
  • Disable the internal UI :
<gui type="internal" enabled="no">