Difference between revisions of "Ubuntu dependencies"

From Navit's Wiki
Jump to: navigation, search
(Copied "Absolute minimum requirements" from Debian page. Not complete, but at least it's closer :-/)
Line 1: Line 1:
 
== Absolute minimum requirements ==
 
== Absolute minimum requirements ==
 
 
* build-essential (this will install various build tools as dependencies)
 
* build-essential (this will install various build tools as dependencies)
 
* pkg-config
 
* pkg-config
 +
* automake
 +
* libglib2.0-dev (or libsdl1.2-dev?)
 +
* libtiff-dev
 
* libtool
 
* libtool
* automake
+
* libxmu-dev
* libglib2.0-dev
+
* libfribidi-dev  
 +
* gettext
 
* zlib1g-dev
 
* zlib1g-dev
* gettext
 
  
 
=Optionals=
 
=Optionals=
Line 14: Line 16:
 
* libgps-dev (required for building GPSD support into navit)
 
* libgps-dev (required for building GPSD support into navit)
  
=GTK Gui=
+
=GTK Gui (needed by default)=
 
* libgtk2.0-dev
 
* libgtk2.0-dev
  
=OpenGL Gui=
+
=OpenGL Gui (needed by default?)=
 +
* freeglut3-dev
 
* glutg3-dev
 
* glutg3-dev
 
* libcegui-mk2-dev
 
* libcegui-mk2-dev
 
* libdevil-dev
 
* libdevil-dev
 +
* libglc-dev

Revision as of 21:26, 23 October 2008

Absolute minimum requirements

  • build-essential (this will install various build tools as dependencies)
  • pkg-config
  • automake
  • libglib2.0-dev (or libsdl1.2-dev?)
  • libtiff-dev
  • libtool
  • libxmu-dev
  • libfribidi-dev
  • gettext
  • zlib1g-dev

Optionals

  • gpsd
  • gpsd-clients
  • libgps-dev (required for building GPSD support into navit)

GTK Gui (needed by default)

  • libgtk2.0-dev

OpenGL Gui (needed by default?)

  • freeglut3-dev
  • glutg3-dev
  • libcegui-mk2-dev
  • libdevil-dev
  • libglc-dev