Ubuntu dependencies

From Navit's Wiki
Revision as of 14:31, 20 May 2012 by Sleske (talk | contribs) (update for CMake build)
Jump to: navigation, search

Packages required for building and running Navit on Ubuntu

These are the packages that must be installed to build and run Navit on Ubuntu. Note that these are not all packages that you need, only the packages that must be installed, i.e. that are not part of the default (desktop) install. If you removed packages after installation, you may have to re-install them.

The list applies to Ubuntu 12.04 LTS (Precise Pangolin). It should be similar for other versions, but if not, please edit this page to correct.

This list is for the CMake build. The build via autotools requires some more packages, but is no longer supported.

Minimum requirements

  • cmake
  • zlib1g-dev
  • libpng12-dev
  • libgtk2.0-dev
  • librsvg2-bin

Note: Not all these packages are strictly required (for example, maptool can be built without installing GTK+), but this is the smallest practical set of packages.

Optionals

GPS support

  • gpsd
  • gpsd-clients
  • libgps-dev (required for building GPSD support into navit)
  • libdbus-glib-1-dev (for dbus bindings)

OpenGL Gui

  • freeglut3-dev
  • libxft-dev

Probably needed (list may be outdated):

  • glutg3-dev
  • libcegui-mk2-dev
  • libdevil-dev
  • libglc-dev
  • libpcre3-dev libmng-dev libfreeimage-dev (ND)

Note: (ND) = not detected by ./configure script, the error pops up during make

Ubuntu source package dependencies

These are the dependencies for compiling Navit with all features. You may not need all of the packages mentioned there, but they can be useful if you experience problems just following the above instructions.

Everything in one command

sudo apt-get install cmake zlib1g-dev libpng12-dev libgtk2.0-dev librsvg2-bin \
gpsd gpsd-clients libgps-dev libdbus-glib-1-dev